
Программа FreeStyler предназначена для создания и воспроизведения световых шоу и управления приборами 

по протоколу DMX512. 

По своей функциональности программа приближается к таким широко известным программам как Martin 

LightJokey и SunLight. При этом в программе реализованы самые необходимые функции. 

FreeStyler будет незаменимой для небольших клубов, ресторанов. Так же как второй пульт управления для 

организаций с большим парком светового оборудования, когда необходимо оперативно оснастить 

дополнительную площадку световым оборудованием, или на короткое время установить световые приборы 

на основной площадке, и перепрограммировать основной пульт нежелательно. 

Интуитивно понятный интерфейс программы позволяет значительно сократить время на освоение. А для тех, 

кто раньше работал с Martin LightJokey и SunLight в интерфейсе ничего нового не будет. 

К достоинством программы можно отнести поддержку более 15 контроллеров DMX. 

Последнюю версию программы можно бесплатно скачать с сайта производителя www.freestylerdmx.be. 

При первом запуске программы, программа предложит указать кантроллер, установленный в Вашей 

системе. В дальнейшем, Вы можете указать контроллер командой меню:  

 

Выберите Ваш контроллер DMX. Если контроллер не установлен, выбирайте "виртуальный 

контроллер" ("Virtual interface"). Нажмите кнопку "Save" и перезапустите программу.  

Кнопка "Reset output" перезагружает контроллер, что позволяет устранить некоторые проблемы, 

возникающие при работе с программой.  

 
 

 

 

 

 

 

 

 

http://www.freestylerdmx.be/


Добавление Устройства. 

Что бы добавить устройство необходимо выбрать пункт меню: Setup - > Add/Remove fixture  

 

Появится список моделей устройств, отсортированных по производителям (столбец слева). Выберете 

необходимое устройство из списка и нажмите кнопку "-> " или перетащите на список справа.  

Затем появится окно установки стартового адреса DMX и количество устанавливаемых устройств 

данной модели. Так же можно отметить установку автоадресации и автоматическое создание группы 

приборов данной модели. Нажатием кнопки "ADD" в таблице справа появятся устройства, 

установленные в Вашей системе с указанием адресного интервала и имени прибора.  

Затем Вы можете скорректировать имя устройства и стартовый адрес DMX. Для этого необходимо 

отметить устройство, в окошке "Start address" указать необходимый начальный адрес DMX и 

нажатием кнопки "set" принять необходимые изменения. В таблице в колонке "Name" введите новое 

название устройства.  

Так же Вы можете отметить следующие опции устройства:  

- Let fixture react to sound when enabled - отметив эту опцию, ваше устройство будет реагировать на 

внешний аудио сигнал  

- Ignore Master intensity - игнорирование мастера интенсивности.  

- Ignore Blackout - игнорирование команды "Blackout".  

 

Для удаления устройства выберите устройство из списка установленных в системе и нажмите кнопку 

" <-".  

 



Прежде чем изменить настройки устройств, сначала необходимо отметить в главной форме 

программы;  

Выбор устройства:  

- Отметьте мышью изображение устройства. Имя устройства будет подсвечено синим цветом. 

Отметив несколько устройств, выделенные устройства будут подсвеченные красным цветом, а 

последнее выделенное - синим.  

 

 

Щелчок мышью на фоновом изображении отменит выделении устройств.  

______________________________________________________________________________________ 

Создание секвенций 

Нажмите на кнопку и откроется главное окно создания последовательностей  

 

Перед созданием секвенций необходимо определить тип секвенции: 

- Статические последовательности не могут быть объединены с другими последовательностями (все 

каналы - "Snap" или "Fade"). 

- "Прозрачные" последовательности могут быть объединен (только каналы, установленные "Snap" 

или "Fade") 

По умолчанию установлено значение "Transparent" - прозрачный. 

Изменить это значение - нажмите по тексту "Transparent Mode" и выберете пункт иеню "Transparent":  



 

Создание секвенций: 

1. Выберите устройство(а), для которого Вы хотите изменить значения DMX. Вы можете изменить 

их, в окне слайдеров или вызывая соответствующие окна управления. 

Устройство, включенное в секвенцию будет помечено значком . 

2. После установки значений DMX, Вы должны установить поведение канала, нажимая кнопку 

Fade/Snap. 

3. Определить продолжительность сцены (значение по умолчанию 1000 ms). 

Если продолжительность сцен в секвенции одинакова, установите опцию "Global Scene Time". 

Для постепенного изменеия каналов, установите "Global Fade"  

 

4. Для создания следующего шага, нажмите кнопку и повторите шаги для создания 

следующего шага секвенции.  

После создания секвенции, сделанную работу необходимо сохранить. Нажмите кнопку и в 

открывшемся окошке дайте имя секвенции  

Другие функции:  

 

Скопировать шаг секвенции  

Вставить шаг секвенции  

Вырезать шаг секвенции  

Отменить последнее изменение секвенции  

 

Удаление секвенции  

Новая секвенция  



 

Вставить шаг секвенции  

 

Записать изменение в редактируемую секвенцию  

Быстрая запись в редактируемую секвенцию без вызова диалогового окна  

 

Тест секвенции: Загрузить предыдущий шаг секвенции  

Загрузить следующий шаг секвенции  

Воспроизвести всю секвенцию  

 

Когда требуется создать волну с несколькими устройствами, необходимо затратить много времени, и 

это не всегда приводит к приемлемым результатам. Используя встроенную функцию этот эффект 

можно создать за несколько секунд!  

 

- Выбрать устройства, которые Вы хотите использовать в эффекте;  

- Выбрать тип волны;  

- Для волны между устройствами Вы должны отметить, "Distribute fixtures evenly", иначе все 

устройства будут иметь одинаковые координаты;  

- Выбрать канал, на который Вы хотите применить волну;  

- Нажмите "Generate", чтобы создать последовательность;  

- Установите постепенное изменение значения каналов ("Fade");  

- Сохранить вашу последовательность  

Объединение нескольких fx-последовательностей в Cue можно мгновенно получить различные 

эффекты. 

  

 



Когда окно Cue открыто, или выполняется другая последовательность окно создания секвенция 

откроется в режиме Offline. Этот режим не будет изменять значения каналов на выходе контроллера.  

Выберите ячейку, значение которой Вы хотите отредактировать. Двойным щелчком мыши введите 

новое значение канала.  

 
 

 

 

 

 

 

 

 

 

 

 

 

 



Воспроизведение секвенций 

Нажмите кнопку на панели инструментов. Появится окно управления воспроизведением 

секвенций:  

 

- в меню нажмите кнопку (в виде шестеренки) и выберете команду " insert sequence" 

- выберете сцену или последовательность, которую Вы хотите вставить и перетащите в список 

секвенций; 

- Повторите, пока все необходимые последовательности не будут загружены в список 

 

Чтобы запустить последовательность, нажмите соответствующую ей кнопку.  

Все последовательности могут выполниться одновременно с приоритетом LTP (последний имеет 

приоритет). (Удостоверьтесь, что Вы отметили опцию " Multiselect") 

Установите скорость воспроизведения последовательности, двигая соответствующий слайдер. 

Правый щелчок мыши на слайдере устанавливает в 100 %. 

Во время воспроизведения Вы можете изменить значения каналов DMX. При этом эти каналы будут 

помечены значком (значение оверрайд). Отменить эти значения можно нажав на эту кнопку.  

Другие функции воспроизведения  

 

скорость воспроизведения секвенции устанавливается вручную;  



 

- Повтор воспроизведения последовательности;  

 

- изменение направления воспроизведения секвенции;  

 

- случайное воспроизведение сцен в последовательности;  

 

- Восстановите значения каналов DMX после остановки последовательности;  

После установки всех вариантов Вы можете сохранить список воспроизведения секвенций. Затем 

быстрым переключением загружать новые списки воспроизведения  

 

Для синхронизации скорости выполняющихся последовательностей с внешним сигналом Вы можете 

использовать кнопку " Tap Sync." Если горит красная лампочка, сигнал синхронизации заблокирован 

и секвенция выполняется с установленных параметром времени. Нажмите два раза кнопку, и 

интервал времени между нажатием кнопок будет равен интервалу времени между шагами 

секвенциями. 

 

 
 

Кнопки вызова списка воспроизведения секвенций  

Эти кнопки используются для вызова заранее настроенных списков воспроизведения секвенций 

(Сие). Если секвенция сохранена в во время воспроизведения, то, в дальнейшем, после загрузки 

списка воспроизведения секвенций эти секвенции будут воспроизводиться сразу одновременно. Для 

этого: 

- Настройте список воспроизведения секвенций (Сuе list). Необходимые секвенции запустите; 

- Сохраните список воспроизведения; 

- откройте диалог настройки кнопок вызова Cue; 

- перетащили команду вызова программы из открытого диалога к в необходимую кнопку. 

 

Если кнопки невидимы - отметьте опцию "Cuelist buttons visible" 

 

 

 



Программирование каналов Панорама/Наклон 

Используйте окно движения луча, чтобы изменить позицию зеркала или световой головы.  

 

Что бы изменить позицию луча, переместите синий круг на координатной плоскости. 

- блокировка движении луча по оси 

 

- изменение скорости движения мыши - изменение разрешающей способности. 

 

- клавиатура для более точного управления движением луча 

- кнопка переключения между абсолютными и относительными координатами (кнопка 

активно и при управлении джойстиком. 

 

Кривые Безье  

Использование кривых Безье можно запрограммировать сложные траектории движения светового 

луча. 

- Откройте bezier редактора, нажимая по кнопке "Shape" 

Откроется окно траектории луча  

 

 

 

 



 

Редактируйте форму, перемещая небольшие квадраты(метки), затем сохраните. При проигрывании 

задайте скорость воспроизведения и кнопкой "On/Off" включите или выключите макрокоманду для 

выбранных устройств  

 

Смещение  

Эта команда определяет смещение луча относительно центра сцены. 

Например, вы имеете 5 лучей, выстроенных в одну линию. Среднийлуч стоит по центру сцены (в 

данном случае центр - это не геометрический центр Вашей площадки, а центр того участка, где 

находятся лучи). Средний луч будет указывать на центр, крайние левый и правый будут иметь 

максимум смещения, а два луча между центральным и крайними будут иметь половинное смещение. 

Смещение центра определяет место нулевого смещения и точку отсчет смещения для остальных 

лучей.  

Настройка размеров Панорама/Наклон 

Иногда, предварительно запрограммированные последовательности для одной площадки Вы хотите 

использовать в другом месте, размеры которого отличаются. Вы можете изменить размеры 

параметров Панорама/Наклон (от 1 до 120 %). 

Для изменения размеров выберете пункт меню Setup -> FreeStyler Setup -> Pan/Tilt resize  

 



Конфигурирование зон 

Большинство клубов имеет различные участки или зоны: танцпол, авансцена, chillout и т.д. 

Эти зоны можно настроить следующим образом: 

- "Setup" -> " Freestyler setup" -> "zones" 

- Отметьте опцию "Enable zones" и получим дополнительно 3 зоны. 

- Дать имя зонам и выберете фоновый рисунок. 

 

 

- Для удаления зоны снимите флажок "Enable zones".  

 



Описание пунктов меню 

Этот раздел дает краткое описание пунктов меню главной формы.  

 

В FreeStyler Вы можете работать с различными настройками для нескольких площадок. Для этого 

необходимо сохранить Ваши настройки, а затем по мере необходимости, загрузить.  

File -> Save Location - сохранение настроек  

File -> Load Location - загрузить предварительно сохраненные настройки  

File -> New Location - новые настройки  

File -> Backup/Restore - создание одного файла с несколькими настройками, необходимыми для 

Вашего шоу (устройства, последовательности, команды вызова программы, параметры настройки...)  

 

Edit -> Background - для изменения фонового изображения выбранной зоны.  

Edit -> Groups… - Создание групп устройств.  

Edit -> Move Fixtures - включает/отключает перемещение значка устройства в главной форме 

программы.  

Edit -> Save as favorite - установка желательного значения устройства. Восстановить эти значения 

можно нажатием кнопки .  

Edit -> Save as Sturtup value - Определяет настройки каждого устройства при запуске программы 

FreeStyler  

Edit -> Show output - показывает значения каналов DMX  

Edit -> Показывает значения входящих данных DMX  



 

Fixture -> Clone Fixture - копирование значения устройства  

Fixture -> Locate selected fixtures : определение местонахождения выбранных устройств в Вашей 

инсталляции. Появится луч белого цвета с нулевыми параметрами Панарама/наклон;  

Fixture -> Copy/paste channel values: используется для копирования значения всех каналов 

выбранного устройства;  

Fixture -> Remove presetvalues: удаление предварительных установок выбранных устройств;  

Fixture -> Remove fixture from sequence - preset - удаление устройства из сцены или 

последовательности;  

Fixture -> Inverse pan/tilt: Инверсия каналов Панорама/Наклон. Инвертированы могут быть любые 

каналы: откройте окно вывода и контекстной (правой) кнопкой мыши выберете пункт "inverse".  

 

Fixture -> Swap pan/tilt: перестановка каналов Панарама/Наклон: Панорама становится Наклоном и 

наоборот.  

Fixture -> Release override settings: отмена значений оверрайд выбранных устройств  

Fixture -> Use in DMX400: конфигурирование устройства для работы с секвенсором DMX400 (только 

для RGB-устройста и диммер-каналов);  

Fixture -> Do not use in DMX400: удаление устройства из секвенсора DMX400;  

Fixture -> Reset fixture: перезагрузка устройства. Посылка значения reset при нажатии клавиши в 

течение 6 секунд.  

Fixture -> Remove fixture from playback: отключение каналов устройства во время работы секвенции 

или сцены.  

Fixture -> Move to zone x: перемещение устройства из одной зоны в другую;  



 

Setup -> Add/remove fixtures - вызывает меню добавления/удаления устройства и конфигурирование 

устройствдобавьте/удалите и конфигурируйте устройства  

Setup -> FreeStyler setup - вызывает меню настройки конфигурации программы FreeStyler  

 

Windows -> All - открывает все окна управления функциями устройств;  

Windows -> Beam - открывает окно управления параметрами луча (фокус, призма и т.д.);  

Windows -> Color - открывает окно управления цветом луча;  

Windows -> Gobo - открывает окно управления gobo;  

Windows ->Light - открывает окно управления лучом (интенсивность, строб);  

Windows ->Pan/Tilt - открывает окно управления движением луча;  

Windows ->Special - открывает окно управления специальными функциями (макросы);  

Windows -> Framing - открывает окно управления фреймами;  

Windows -> Create 2510 controller file - Создает файл, который можно загрузить в контроллер 

Мартину-2510 (предварительно он должен быть установлен);  

Widows -> Reset windows position - если некоторые окна не отображены на экране, возможно, они 

находятся за пределами отображения экрана. Этот пункт меню "обнуляет" позицию этих окон;  

 

 

 

 



Панель управления 

 

- выделение всех устройств или группы;  

 

- отмена выделения;  

 

- открывает окно управления параметрами луча (фокус, призма и т.д.);  

 

- открывает окно управления gobo;  

 

- открывает окно управления цветом луча;  

 

- открывает окно управления движением луча;  

 

- открывает окно управления параметрами луча (фокус, призма и т.д.);  

 

- открывает окно управления специальными функциями (макросы);  

 

- открывает все окна управления функциями устройств;  

 

- открывает приложение 3В-визуализации Magic 3D Easy View;  

 

- открывает окно создания последовательности или сцены;  



 

- вызывает панель управления последовательностями Cue;  

 

- вызывает панель программируемых кнопок;  

 

- вызывает панель субмастеров;  

 

- активация управления устройств от внешнего аудио сигнала;  

 

- вызывает окно управления дым-машинами, хейзерами и т.д.  

 

- включает секвенсор DMX-400;  

 

- вкючение/отключение блэкаута (ЗТМ);  

 

- установка предварительно определенных значений;  

 

- пауза в выполнении секвенций;  

 

- открывает окно грандмастера;  

 

- выполнение команд с использованием цифровой клавиатуры. Например: "2+3*50%" - значения 2 и 

3 каналов установлены в 50% или "1-20*100 %", значения каналов с 1 по 20 установлены в 100%;  



 

- отмена значений оверрайд;  

_________________________________________ 

Работа с клавиатурой 

Используя клавиатуру или джойстик можно управлять наиболее важными и часто используемыми 

функциями. 

Что бы настроить программу необходимо выбрать пункт меню: 

- "Setup" -> "FreeStyler setup" -> "Keyboard shortcuts" 

- Отметьте необходимую функцию (отметится синим фоном) и нажмите на соответствующую 

клавишу (сочетание клавиш). 

- Для удаления команды нажмите левую кнопку мыши на соответствующей команде  

 

 
 

 

 

 

 

 



Работа с джойстиком 

Вы можете управлять джойстиком функциями Панорама/Наклон и настроить кнопки джойсика дляя 

управления другими функциями программы.  

Для этого необходимо перейти в пункт меню "Setup" -> "FreeStyler setup" -> "Joystics control" и 

отметить опцию "Enable Joystick control".  

Для включения и выключения управления функциями программы необходимо запрограммировать 

клавишу клавиатуры (сочетание клавиш) на выполнение функции "Enable Joystick".  

 
 

Управление с помощью MIDI 

Используя MIDI-клавиатуру можно управлять всеми функциями программы FreeStyler. Сначала 

необходимо выбрать пункт меню "Setup" -> "FreeStyler setup" -> "MIDI control". 

Затем выберете MIDI-контроллер, установленный на компьютере и нажмите кнопку "Start", что бы 

FreeStyler получил сигналы MIDI. 

Присвойте каждой функции номер канала MIDI и нажмите "Assign Notes", 

Доступно 5 различных страниц и страница independant. 

выберите необходимую функцию, страницу и нажмите на вашем контроллере MIDI необходимую 

кнопка / микшер 

Для очищения команды MIDI нажмите "Delete". 

Нажмите "Edit" снова, чтобы войти в режим редактирования.  

 



 

Установка пароля 

Установка пароля ограничит доступ ко всем параметрам настройки, никакие изменения не могут 

быть сделаны.  

 

Установить пароль:  

- "Setup" -> "Freestyler setup" -> "Password"  

- Введите пароль  

- Повторите ввод пароля  

 

Когда Вы хотите изменить текущий пароль, Вы должны ввести старый и два раза ввести новый 

пароль  

 

Если Вы хотите заблокировать защиту - выберете пункт меню "File" - "Enter password and disable 

security". И если пароль правилен, все параметры настройки станут снова доступными.  

 

 

 

 



Изменение значений каналов DMX 

При выборе прибора для редактирования, становится доступным панель слайдеров, которыми Вы 

можете значения выбранного. Для вызова панели слайдеров необходимо невести указатель мыши на 

значок в правом верхнем углу главной формы программы FreeStyler  

 

Кнопка при каждом слайдере определяет как изменяется параметр: 

- Fade - параметр изменяется равномернени шага последовательности; 

- Snap - параметр изменяется мгновенно; 

- Off - канал в последовательности не участвует; 

- отмена значений оверрайд данного канала  

Группы 

В FreeStyler Вы можете создать до 24 групп устройств  

 

Создавать группу:  

- Выберете пункт меню "Edit"-> "Groups" или правой кнопкой мыши нажмите на фоновом 

изображении и в появившемся меню выберете пункт "Groups".  

- Введите имя новой группы и выбирете пункт меню "Add Group".  

- Выделите всѐ устройства, которые Вы хотите добавить в группу  

- Выберете пункт меню "Add fixtures". Вы увидите дерево выбранных устройств.  

 



Удаление элементов группы: 

- Выберете группу или элемент группы нажмите "Remove item". 

 

Для выбора и отмены выбора группы используйте кнопки на панели управления.  

 

 

Создание и использование пресетов 

Нажмите на кнопку вызова создания секвенций .  

 

Справа появится следующий экран: . 

Нажмите на него и появится окно менеджера пресетов  

 

Freestyler имеет два типа пресета: локальный пресет и глобальный пресет.  

- локальный пресет устанавливает значения для одного устройства и может быть применено на 

другие устройства того же типа;  

- Глобальный пресет устанавливает значения для всех устройств, сконфигурированных в программе 

FreeStyler.  

 

Создание пресета  



- Открыть редактор секвенций  

- Выбрать одно устройство для создания локального пресета или несколько устройств для 

глобального;  

- Сделать необходимые изменения (каналы должны быть установлены активными: "Snap" или 

"Fade")  

- В окне пресета укажите номер пресета и нажмите, "Save preset""  

- Значок указывает на тип пресета.  

- Дать имя пресета  

 

Использование пресета  

- Открытый или создайте новую последовательность;  

- выбрать устройства, к которым Вы хотите применить пресет  

- выбрать пресет  

- нажмите кнопку "Apply to sel. fix…" Красный значок указывает на применение пресета  

 

Редакция пресета  

- Правый щелчком мыши на пресете вызовете меню и выберете пункт "Edit preset"  

- Пресет загружается в редактор секвенций для редактирования;  

- После редактирования Вы должны нажать " Save preset ", чтобы сохранить изменения  

 

Удаление пресета  

- Правым щелчком мыши на пресете вазовете меню и выберете пункт "Delete preset";  

 

Удаление настроек пресета из устройства в секвенциии  

- правым щелчком мыши на устройстве и выберете "Remove presets" (необходимо повторить для 

каждого шага секвенции)  

Субмастера 

В каждый субмастер Вы можете загрузить секвенцию и слайдером управлять каналами 

интенсивности. При этом соблюдается приоритет НTP.  

 

Что бы запустить секвенцию в субмастере, нажмите кнопку "Run", остановить - кнопку "Stop".  

Вы можете выбрать другую последовательность, щелкая "Go", и "Back". Когда работает один из 

Субмастеров, Вы не можете использовать команду вызова программы, потому что они используют ту 



же самую систему!!  

 

Когда открыто окно cубмастера, воспроизводящего секвенцию, обновление каналов интенсивности 

заблокировано из других окон программы!!!  

 

Может быть сконфигурировано и запущено одновременно до 20 субмастеров.  

Программируемые кнопки 

Программируемые кнопки используются, чтобы запустить секвенцию с самым высоким 

приоритетом. Значения каналов будут переданы как значения оверрайд, поэтому они имеют самый 

высокий приоритет в Freestyler (LTP). Кнопки могут быть конфигурированы как с фиксацией, так и 

без фиксации (flash button). Эти кнопки могут использоваться для управления стробами, диммер 

каналами и т.д.  

 

Конфигурирование кнопок:  

 

- нажмите кнопку вызова меню настройки. Выберете сцену командой "Insert scenes".  

 



- перетащите сцену из списка сцен на кнопку.  

- наведите курсор мыши на кнопку и правой кнопкой мыши вызовите меню конфигурации кнопки.  

 

Изменения, внесенные программируемыми кнопками будут иметь более высокий приоритет, чем 

другие изменения оверрайд..  

 

FreeStyler поддерживает 6 страниц по 30 кнопок на каждой странице (всего 180 программируемых 

кнопок)  

______________________________________________________________________________________ 

Источник: http://lasser.narod.ru/index.html  сайт компании "Альянс-НК" 

Вопросы и пожелания отправляйте: lasser@yandex.ru с пометкой DMX512 

http://lasser.narod.ru/index.html

